Public Vulnerability Reports

Exim auth_spa_server() Buffer Overflow Vulnerability

01.07.05

BACKGROUND

Exim is a message transfer agent developed for use on Unix systems. More
information is available at:

 http://www.exim.org/

DESCRIPTION

Remote exploitation of a buffer overflow vulnerability in Exim 4.41 may
allow execution of arbitrary commands with elevated privileges.

Exim is a message transfer agent developed for use on Unix systems. The
problem specifically exists in the auth_spa_server function. The
function fails to check the length of input to spa_base64_to_bits(),
which decodes a Base64-encoded string into a buffer of a fixed length.
This string is user-controlled and passed to the program from a remote
connection.

ANALYSIS

Exploitation of this vulnerability will give an attacker remote access
to the mailer uid. The exim mailer is setuid root, but drops privileges
before the vulnerable code is reached. A remote attacker may be able to
use other vulnerabilities to further elevate their privileges.

This vulnerability is only exploitable when the spa authentication
method has been configured by setting AUTH_SPA=yes in Local/Makefile
when building it.

DETECTION

Exim versions 4.40 and 4.41 have been confirmed vulnerable. The source
code for version 4.42 suggests that it is vulnerable. It is suspected
that previous versions are also vulnerable.

To determine if the Exim version being used is vulnerable, connect to
port 25 of the machine with Exim installed and type:

   EHLO localhost

If AUTH NTLM appears in the output the application may be vulnerable.

WORKAROUND

iDEFENSE is currently unaware of any effective workarounds for this
vulnerability.

VENDOR RESPONSE

The vulnerability has been fixed in Exim release 4.44.

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2005-0022 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

DISCLOSURE TIMELINE

12/23/2004   Initial vendor notification
12/29/2004   Initial vendor response
01/07/2004   Coordinated public disclosure

CREDIT

The discoverer of this vulnerability wishes to remain anonymous.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

LEGAL NOTICES

Copyright © 2004 Verisign, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.