Public Vulnerability Reports

IBM AIX chcod Local Privilege Escalation Vulnerability

12.20.04

BACKGROUND

The chcod program is a setuid root application, installed by default
under newer versions of IBM AIX, that manages capacity upgrade on demand
(CUoD).

DESCRIPTION

Local exploitation of an untrusted path vulnerability in the chcod
command included by default in multiple versions of IBM Corp. AIX could
allow for arbitrary code execution as the root user.

During execution, chcod invokes an external application ("grep") while
trusting the user specified PATH environment variable. Root privileges
are not dropped before this execution occurs, thus allowing an attacker
to gain root access by specifying a controlled path and creating a
malicious binary within that path.  All an attacker needs to do to
exploit the vulnerability is create a file called grep which contains
malicious code, set their PATH variable to the current directory, and
execute /usr/sbin/chcod.

ANALYSIS

The impact of this vulnerability is lessened by the fact that an
attacker must first gain access to the "system" group in order to use
this binary.  Once group id "system" has been acquired, all that is
required to exploit this vulnerability is a writable directory.  This
directory can be the user's home directory, or even the /tmp directory,
provided setuid execution is allowed. Exploitation does not require any
knowledge of application internals, making privilege escalation trivial,
even for unskilled attackers.

DETECTION

iDEFENSE has confirmed the existence of this vulnerability in IBM AIX
version 5.2. It is suspected that previous versions are also
vulnerable. 

WORKAROUND

Only allow trusted users local access to security critical systems.
Only allow trusted users access to the system group.  Alternately,
remove the setuid bit from chcod using chmod u-s /usr/sbin/chcod.

VENDOR RESPONSE

"IBM provides the following fixes:

      APAR number for AIX 5.1.0: IY64356 (available)
      APAR number for AIX 5.2.0: IY64355 (available)
      APAR number for AIX 5.3.0: IY64354 (available)

NOTE: Affected customers are urged to upgrade to 5.1.0, 5.2.0 or 5.3.0
at the latest maintenance level."

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2004-1028 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

DISCLOSURE TIMELINE

11/02/2004        Initial vendor notification
11/04/2004        Initial vendor response
12/20/2004        Coordinated public disclosure

CREDIT

iDEFENSE Labs is credited with this discovery.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

LEGAL NOTICES

Copyright © 2004 Verisign, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.