// back

Adobe Flash Media Server 2 Multiple Integer Overflow Vulnerabilities

12.02.08

BACKGROUND

Adobe Flash Media Server is an application server for Flash based applications. It provides an environment to run interactive media applications, as well as audio and video streaming functionality. More information can be found at the vendor's web site at the following URL.

http://www.adobe.com/products/flashmediaserver/

DESCRIPTION

Remote exploitation of multiple integer overflow vulnerabilities in Adobe Systems Inc.'s Flash Media Server 2 could allow an unauthenticated attacker to execute arbitrary code with SYSTEM privileges.

The Flash Media Server contains a component called the Edge server, which listens on TCP ports 1935 and 19350 for incoming connections. This port is the primary port used for client/server communication. The Edge server speaks the Real Time Message Protocol, or RTMP, a proprietary binary protocol developed by Adobe.

These vulnerabilities exist within the code responsible for parsing RTMP messages. In each case, a 32-bit value taken directly from the packet is used in an arithmetic operation to calculate the number of bytes to allocate for a dynamic buffer. This operation can overflow, which later leads to a heap overflow.

ANALYSIS

Exploitation of these vulnerabilities results in the execution of arbitrary code with SYSTEM level privileges. In order to exploit these vulnerabilities, an attacker only needs the ability to connect to the target server on TCP port 1935 or 19350.

Unsuccessful attempts at exploitation will likely result in the Edge server crashing. After crashing, the Edge server will be restarted automatically. This gives an attacker an unlimited number of attempts at exploitation.

DETECTION

iDefense has confirmed the existence of these vulnerabilities in Flash Media Server 2 version 2.0.4 on Windows. Previous versions, as well as the Linux version, may also be affected.

WORKAROUND

iDefense is currently unaware of any workarounds for this issue.

VENDOR RESPONSE

Adobe has addressed these vulnerabilities by releasing version 2.0.5 of Flash Media Server. For more information, consult their bulletin at the following URL.

http://www.adobe.com/support/security/bulletins/apsb08-03.html

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2007-6149 to this issue. This is a candidate for inclusion in the CVE list (http://cve.mitre.org/), which standardizes names for security problems.

DISCLOSURE TIMELINE

11/27/2007 Initial vendor notification
11/27/2007 Initial vendor response
02/12/2008 Coordinated public disclosure

CREDIT

These vulnerabilities were reported to VeriSign iDefense by Sebastian Apelt.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php

Free tools, research and upcoming events
http://labs.idefense.com/

LEGAL NOTICES

Copyright © 2008 Verisign, Inc.

Permission is granted for the redistribution of this alert electronically. It may not be edited in any way without the express written consent of iDefense. If you wish to reprint the whole or any part of this alert in any other medium other than electronically, please e-mail customer service for permission.

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.