// back

Adobe Reader and Acrobat Multiple Stack-based Buffer Overflow Vulnerabilities

08.02.08

BACKGROUND

Adobe Reader is a program for viewing Portable Document Format (PDF) documents. Acrobat is the program used to create such documents. More information is available at the following URLs.

http://www.adobe.com/products/acrobat/
http://www.adobe.com/products/reader/

DESCRIPTION

Remote exploitation of multiple stack-based buffer overflows in JavaScript methods in Adobe Reader and Acrobat could allow an attacker to execute arbitrary code as the current user.

These issues exist due to insufficient input validation in several JavaScript methods. Inadequate checking is performed on the string length before it is copied into a fixed sized buffer on the stack. If an attacker supplies a long string, control structures on the stack may be modified, allowing the execution of arbitrary code.

ANALYSIS

Exploitation of these vulnerabilities would allow an attacker to execute arbitrary code as the current user. In order to exploit these vulnerabilities, an attacker would have to convince a targeted user to open a maliciously constructed file. This file could be sent directly to the targeted user or linked from a website.

DETECTION

iDefense has confirmed these vulnerabilities exist in Adobe Reader 8.1 on Windows XP SP2. It is likely that other Adobe products that handle PDF files, including previous versions of Adobe Reader, are also affected.

WORKAROUND

Disabling JavaScript in Adobe Reader or Acrobat will limit exposure to these vulnerabilities. When JavaScript is disabled, Adobe Reader will prompt the user that some components of the document may not function, and provide an opportunity to enable it.

VENDOR RESPONSE

Adobe released version 8.1.2 of Adobe Reader and Acrobat to address these vulnerabilities. Although there is currently no update for version 7.0.9, Adobe reports it does plan to release one at a later date. For more information, visit the vendor's advisory at the following URL.

http://www.adobe.com/support/security/advisories/apsa08-01.html

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2007-5659 to this issue. This is a candidate for inclusion in the CVE list (http://cve.mitre.org/), which standardizes names for security problems.

DISCLOSURE TIMELINE

10/10/2007 Initial vendor notification
10/10/2007 Initial vendor response
10/26/2007 Request for status
10/26/2007 Status - Est. early January
01/04/2008 Request for status
01/04/2008 Status - Scheduled early February
01/28/2008 Adobe plans patch for 8, but not 7
01/30/2008 Concerns about the plan e-mailed to Adobe
01/31/2008 Telephone call to clarify concerns
02/06/2008 Adobe releases 8.1.2
02/06/2008 Immunity makes PoC available to partners
02/07/2008 Adobe publishes APSA08-01
02/08/2008 Exploit discovered in the wild
02/08/2008 Public disclosure

CREDIT

These vulnerabilities were discovered by Greg MacManus of VeriSign iDefense Labs.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php

Free tools, research and upcoming events
http://labs.idefense.com/

LEGAL NOTICES

Copyright © 2008 Verisign, Inc.

Permission is granted for the redistribution of this alert electronically. It may not be edited in any way without the express written consent of iDefense. If you wish to reprint the whole or any part of this alert in any other medium other than electronically, please e-mail customer service for permission.

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.