// back

Multiple Vendor ImageMagick Multiple Integer Overflow Vulnerabilities

09.19.07

BACKGROUND

ImageMagick is a suite of image manipulation tools (animate, composite, conjure, convert, display, identify, import, mogrify and montage) that are sometimes used by other applications for processing image files. For more information about ImageMagick, visit the vendor's site at the following URL.

http://www.imagemagick.org/

DESCRIPTION

Remote exploitation of multiple integer overflow vulnerabilities in ImageMagick, as included in various vendors' operating system distributions, allows attackers to crash applications using the ImageMagick library, and in some cases, execute arbitrary code.

Several integer overflow vulnerabilities have been identified in ImageMagick's handling of various file formats. By creating a specially crafted DCM, DIB, XBM, XCF, or XWD image file, an attacker can cause a heap buffer of insufficient size to be allocated. This results in a heap-based buffer overflow.

ANALYSIS

Exploitation of these vulnerabilities allows an attacker to crash the programs using ImageMagick library, or execute arbitrary code in the context of the user.

One way of exploiting these vulnerabilities is to persuade a targeted user to open a malicious image file with a program that utilizes the ImageMagick library.

As the tools that are part of ImageMagick are sometimes used as helper tools by other applications, this user may be the same as the web server user. This scenario is somewhat more severe than the previously described attack vector since the image processing can occur automatically.

DETECTION

iDefense Labs confirmed that ImageMagick version 6.3.4 is vulnerable. It is suspected that other versions of ImageMagick are also vulnerable.

WORKAROUND

Exposure to some of these vulnerabilities can be mitigated by moving or deleting the related module files. The file locations may vary between distributions. The globbing expressions listed below correspond to a Red Hat Linux system.

 /usr/lib/ImageMagick-*/modules*/coders/dcm.* /usr/lib/ImageMagick-*/modules*/coders/dib.* /usr/lib/ImageMagick-*/modules*/coders/xbm.* /usr/lib/ImageMagick-*/modules*/coders/xcf.* /usr/lib/ImageMagick-*/modules*/coders/xwd.* 

VENDOR RESPONSE

The ImageMagick maintainers have addressed these vulnerabilities with the release of version 6.3.5-9. More information is available from the following URL.

http://studio.imagemagick.org/pipermail/magick-announce/2007-September/000037.html

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2007-4986 to this issue. This is a candidate for inclusion in the CVE list (http://cve.mitre.org/), which standardizes names for security problems.

DISCLOSURE TIMELINE

09/04/2007 Initial vendor notification
09/05/2007 Initial vendor response
09/19/2007 Coordinated public disclosure

CREDIT

These vulnerabilities were reported to iDefense by regenrecht.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php

Free tools, research and upcoming events
http://labs.idefense.com/

LEGAL NOTICES

Copyright © 2007 Verisign, Inc.

Permission is granted for the redistribution of this alert electronically. It may not be edited in any way without the express written consent of iDefense. If you wish to reprint the whole or any part of this alert in any other medium other than electronically, please e-mail customer service for permission.

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.