// back

Denial of Service Vulnerability in Linksys Cable/DSL Routers

11.19.02

BACKGROUND

Linksys Group Inc. currently sells several broadband router products, including:

BEFW11S4, Wireless Access Point Router with 4-Port Switch - Version 2
BEFSR11, EtherFast® Cable/DSL Router
BEFSR41, EtherFast® Cable/DSL Router with 4-Port Switch
BEFSRU31, EtherFast® Cable/DSL Router with USB and 3-Port Switch

More information is available at http://www.linksys.com/products/group.asp?grid=23 .

DESCRIPTION

The BEFW11S4, BEFSR11, BEFSR41 and BEFSRU31 can be crashed when several thousand characters are passed in the password field of the device's web management interface. Exploitation simply requires the use of a web browser that can send long Basic Authentication fields to the affected router's interface.

ANALYSIS

Remote exploitation is only possible if the remote web management interface is enabled (this is disabled by default). An attacker on the internal network can access the web management interface by using a web browser and accessing the URL http://192.168.1.1 (default URL).

DETECTION

The BEFW11S4, BEFSR11, BEFSR41, and BEFSRU31 devices with firmware
earlier than version 1.43.3 are affected.  iDEFENSE confirmed susceptibility on the BEFW11S4. Linksys indicated that the BEFSR11, BEFSR41 and BEFSRU31 are also affected.

WORKAROUND

Disable the remote web management interface on the affected router.

VENDOR RESPONSE

Linksys firmware 1.43.3, which is available at http://www.linksys.com/download/, fixes the problem on all the affected devices.

CVE INFORMATION

The Mitre Corp.'s Common Vulnerabilities and Exposures (CVE) Project assigned the identification number CAN-2002-1312 to this issue.

DISCLOSURE TIMELINE

11/02/2002 Issue disclosed to iDEFENSE
11/06/2002 Linksys notified (jay.price@linksys.com)
11/11/2002 Linksys response (diana.ying@linksys.com)
11/18/2002 iDEFENSE clients notified
11/19/2002 Public disclosure

CREDIT

Alex S. Harasic (aharasic@terra.cl) discovered this vulnerability.