// back

Linksys WRT54G Management Interface DoS Vulnerability

09.13.05

BACKGROUND

The Linksys WRT54G is a combination wireless access point, switch and
router. More information is available at the following URL:

  http://www.linksys.com/products/product.asp?prid=508

DESCRIPTION

Remote exploitation of an input validation error within the web
management httpd component of Cisco Systems Inc.'s Linksys WRT54G
wireless router may allow unauthenticated users to cause a denial of
service (DoS).

The vulnerability exists in several of the "POST" method handlers of the
httpd running on the router's internal interfaces, including by default
the wireless interface. In addition to not checking if authentication
has failed until after data supplied by an external user has been
processed, there are several places where the Content-Length is assumed
to be valid. In some of those cases, data is read in without error
checking while decrementing the length value. If the Content Length is
set to a negative number, these checks will take an extremely long time,
during which the httpd will become unresponsive.

ANALYSIS

An unauthenticated remote attacker may cause a DoS on the affected
router. Exploitation of this vulnerability would require that an
attacker can connect to the web management port of the router. The httpd
is running by default, but is only accessible via the LAN ports or the
WLAN (wireless LAN).

Although this DoS is against the httpd itself, it may cause a higher
than normal load on the router, which may be sufficient to cause packet
loss. The httpd will also be unavailable. This may be sufficient to
cause to owner to restart the device, which could in turn trigger
changes made by a previous vulnerability.

DETECTION

iDEFENSE has confirmed the existence of this vulnerability in version
3.01.3 of the firmware of the Linksys WRT54G wireless router, and has
identified the same code is present in versions 3.03.6 and 4.00.7.
All versions prior to 4.20.7 may be affected.

WORKAROUND

To mitigate exposure of the internal network to outside attackers,
ensure encryption is enabled on the wireless interface. The exact
settings to use depend on your wireless deployment policies.

VENDOR RESPONSE

Linksys has addressed this issue in version 4.20.7 of the firmware for the WRT54G Router.

Additionally, this vulnerability was fixed in version 1.05.2 of the WRT54GS router, with version 4 hardware.

CVE INFORMATION

A Mitre Corp. Common Vulnerabilities and Exposures (CVE) number has not
been assigned yet.

DISCLOSURE TIMELINE

07/05/2005 Initial vendor notification
07/25/2005 Initial vendor response
09/13/2005 Coordinated public disclosure

CREDIT

This vulnerability was discovered by Greg MacManus of iDEFENSE Labs.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

Free tools, research and upcoming events
http://labs.idefense.com

LEGAL NOTICES

Copyright © 2005 Verisign, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.