// back

MPlayer Bitmap Parsing Remote Heap Overflow Vulnerability

12.16.04

BACKGROUND

MPlayer is a movie player for Linux that also runs on many other Unices,
and non- x86 CPUs. It plays most MPEG, VOB, AVI, Ogg/OGM, VIVO,
ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, NuppelVideo, YUV4MPEG, FILM, RoQ, PVA
files, supported by many native, XAnim, and Win32 DLL codecs. You can
watch VideoCD, SVCD, DVD, 3ivx, DivX 3/4/5 and other formats.

More information is available at http://mplayerhq.hu/.

DESCRIPTION

Remote exploitation of a heap overflow vulnerability in Unix MPlayer
could allow attackers to gain access to the computer.

The vulnerability specifically exists due to a lack of bounds checking
within the demux_open_bmp() routine defined in /libmpdemux/demux_bmp.c.
If a specially crafted file specifies a large value for the "biClrUsed"
field, an overflow is triggered in stream_read().

The vulnerable portion of code is displayed here:

demuxer_t* demux_open_bmp(demuxer_t* demuxer)
{
    sh_video_t *sh_video = NULL;
    unsigned int filesize;
    unsigned int data_offset;
    bmp_image_t *bmp_image;
    ...
    sh_video->bih->biClrUsed = stream_read_dword_le(demuxer->stream);
    sh_video->bih->biClrImportant = stream_read_dword_le(demuxer->stream);
    // fetch the palette
[!]  stream_read(demuxer->stream, (unsigned char *)(sh_video->bih) + 40,
    sh_video->bih->biClrUsed * 4);
    ...
}

In the given example call to stream_read(), an unchecked amount of data
as specified by "biClrUsed" will be read into the fixed size buffer
"bih." This allows control of execution by overwriting the saved return
address on the stack.

ANALYSIS

Successful exploitation of this vulnerability allows remote attackers to
execute arbitrary code under the privileges of the user who attempted to
view the bitmap file. Exploitation is not trivial, as a high level of
precision is required. It is not a requirement for the malicious file to
have an extension of .bmp because MPlayer will correctly determine if it
is a bitmap file despite its extension.

DETECTION

iDEFENSE has confirmed that MPlayer version 1.0pre5 is vulnerable.

The following distributions of Linux include MPlayer:
 
 Gentoo Linux
 SUSE Linux

WORKAROUND

Users must be careful when accepting and opening media from untrusted
sources.

VENDOR RESPONSE

A patch to address this vulnerability is available at:

http://www1.mplayerhq.hu/MPlayer/patches/bmp_fix_20041215.diff

CVE INFORMATION

A Mitre Corp. Common Vulnerabilities and Exposures (CVE) number has not
been assigned yet.

DISCLOSURE TIMELINE

12/10/2004   Initial vendor notification
12/16/2004   Public disclosure

CREDIT

The discoverer of this vulnerability wishes to remain anonymous.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

LEGAL NOTICES

Copyright © 2004 Verisign, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.