// back

Adobe Flash Player Flash Video File Parsing Heap Overflow Vulnerability

02.12.13

BACKGROUND

Adobe Flash Player runs SWF files that can be created by the Adobe Flash authoring tool, by Adobe Flex, or by a number of other Macromedia and third-party tools. For more information, please visit the following website:

http://www.adobe.com/products/flashplayer/

DESCRIPTION

Remote exploitation of a heap buffer overflow vulnerability in Adobe Systems Inc.'s Flash Player could allow an attacker to execute arbitrary code with the privileges of the current user. Adobe Flash Player is an application for viewing animations and movies using computer programs such as a Web browser; in common use, Flash lets users put animation and movies on a website.

The vulnerability occurs when parsing a specially crafted Flash video (.flv) file. When decoding ADPCM audio in a Flash video file, Flash Player fails to properly validate a buffer size. This results in a heap-based buffer overflow and can lead to the execution of arbitrary code.

ANALYSIS

Exploitation of this vulnerability results in the execution of arbitrary code with the privileges of the user viewing the Web page. To exploit this vulnerability, a targeted user must load a malicious Web page that an attacker creates. An attacker typically accomplishes this via social engineering or injecting content into compromised, trusted sites. After the user visits the malicious Web page, no further user interaction is needed. The attacker can also deliver this exploit through a Microsoft Office document either by embedding a Flash file directly into an Office document or by running JavaScript script to load the Flash file from a website within an Office document. The attacker needs to convince a user to open such an Office document using social engineering methods.

DETECTION

The following versions of Adobe Flash are vulnerable:

  • Adobe Flash Player versions prior to 11.6.602.168 for Windows
  • Adobe Flash Player versions prior to 11.6.602.167 for Macintosh
  • Adobe Flash Player versions prior to 11.2.202.270 for Linux
  • Adobe Flash Player versions prior to 11.1.115.47 for Android 4.x
  • Adobe Flash Player versions prior to 11.1.111.43 for Android 3.x and 2.x
  • Flash Player versions prior to 11.6.602.167 for Internet Explorer 10 for Windows 8
  • Flash Player versions prior to 11.6.602.167 for Chrome users (Windows, Macintosh and Linux)
  • Adobe AIR prior to version 3.6.0.597
  • Adobe AIR prior to version 3.6.0.599 SDK
  • Adobe AIR prior to version 3.6.0.597 for Android

WORKAROUND

Disable or uninstall Flash Player, or only allow it to run from trusted websites. This can be performed by changing the permissions on the Flash plug-in binary or by browser plug-in configuration options. This workaround may prevent websites relying on Flash technology from working properly.

VENDOR RESPONSE

Adobe has released a fix which addresses this issue. For more information, consult their advisory at the following URL:

http://www.adobe.com/support/security/bulletins/apsb13-05.html

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2013-0638 to this issue. This is a candidate for inclusion in the CVE list (http://cve.mitre.org/), which standardizes names for security problems.

DISCLOSURE TIMELINE

12/14/2012 Initial Vendor Notification
12/14/2012 Initial Vendor Reply
02/12/2013 Coordinated Public Disclosure

CREDIT

This vulnerability was reported to iDefense by Damian Put.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php

Free tools, research and upcoming events
http://labs.idefense.com/

LEGAL NOTICES

Copyright © 2013 Verisign, Inc.

Permission is granted for the redistribution of this alert electronically. It may not be edited in any way without the express written consent of iDefense Verisign. If you wish to reprint the whole or any part of this alert in any other medium other than electronically, please e-mail customer service for permission.

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.