Public Vulnerability Reports

Darwin Streaming Server Remote Denial of Service Vulnerability

02.23.04

BACKGROUND

Darwin Streaming Server is server technology allowing for the streaming
of QuickTime data to clients across the Internet using the industry
standard RTP and RTSP protocols.

DESCRIPTION

Exploitation of a flaw in Apple Computer Inc's Darwin Streaming Server
allows unauthenticated remote attackers to prevent legitimate usage.

The vulnerability specifically occurs upon parsing of DESCRIBE requests
with specially crafted User-Agent fields. Making a request with a
User-Agent field containing over 255 characters causes an assert error
in CommonUtilitiesLib/StringFormatter.h line 97:

virtual void BufferIsFull(char* /*inBuffer*/, UInt32/*inBufferLen*/)
{
    Assert(0);
}

Successful exploitation disrupts further content streaming
capabilities.

ANALYSIS

Any remote unauthenticated attacker can exploit the vulnerability
thereby preventing legitimate users from accessing streamed content.

iDEFENSE has obtained proof of concept exploit code for this
vulnerability.

DETECTION

iDEFENSE has confirmed that the latest version of Darwin Streaming
Server, version 4.1.3, is vulnerable.

VENDOR RESPONSE

This is fixed in Security Update 2004-02-23 available for Mac OS X
10.3.2 Server and Mac OS X 10.2.8 Server.  The update and further
information is available from Apple's Support site at:
http://www.apple.com/support/

CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
CAN-2004-0169 to this issue. This is a candidate for inclusion in the
CVE list (http://cve.mitre.org), which standardizes names for security
problems.